The Sympa Community 2020-05-27 (Update)
A fix is available for a vulnerability discovered in Sympa web interface.
A vulnerability has been discovered in Sympa web interface by which attacker can execute arbitrary code with root privileges.
Sympa uses two sorts of setuid wrappers:
The FastCGI wrappers
were used to make the web interface running under privileges of a
The newaliases wrapper (
sympa_newaliases-wrapper) allows Sympa to
update the alias database with root privileges.
Since these setuid wrappers did not clear environment variables,
if environment variables like
PERL5LIB were injected, forged code
might be loaded and executed under privileges of setuid-ed users.
For more details see References.
Attacker can execute arbitrary code with root privileges.
Stop using FastCGI wrappers and remove them
Modify configuration for HTTP server so that it will not use the wrapper. For detailed instructions see:
Remove executable files of FastCGI wrappers (replace $EXECCGIDIR below: See https://sympa-community.github.io/manual/layout.html):
# cd $EXECCGIDIR # rm wwsympa-wrapper.fcgi # rm sympa_soap_server-wrapper.fcgi
Note that newaliases wrapper may not be removed.
No workaround has been known about some obsoleted systems requiring FastCGI wrapper, in particular Apache HTTP Server 2.2.x and earlier.
Upgrade to version 6.2.56
or, if you have installed Sympa using earlier version of source distribution,
Apply a patch to the source, recompile wrappers and reinstall them:
Patch for sympa-6.2 or later: sympa-6.2.54-sa-2020-002-r2.patch
Patch for sympa-6.1.25: sympa-6.1.25-sa-2020-002-r2.patch
The security flaw this advisory describes was reported by Nicolas Chatelain, Sysdream Labs.
Initial version published.
CVE Numbers: Confirmed that CVE-2020-10936 has been assigned.
References: Adding report by Nicolas.
Solution: Adding patch for Sympa 6.1.25
Theme originally designed by orderedlist